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Relative warp analysis

Programs

The key set of programs you’ll need is Jim Rohlf’s tps suite (http://life.bio.sunysb.edu/morph/).
1. tpsUtil. This program will allow you to build tps files with very little hassle.

2. tpsDig. This program will allow you to place landmarks on your images and record scale factors, saving
this data in the tps file.

3. tpsRelw. This aligns the specimens and computes partial and relative warps.

You will also want a text editor (e.g., Notepad or Word), a spreadsheet editor (e.g., Excel), and a stats pack-
age (e.g., SPSS, SAS, many others, even Excel). An image processing program like Photoshop is very help-
ful.

Imaging

1. Leave space around your image during photography. If your image fills the frame, it will likely be distort-
ed near the edges. You can still crop your image afterwards (e.g., in Photoshop).

2. Take photos at max available resolution. Storage is cheap, so don’t needlessly shrink your images just to
save disk space. You may want that information later. Images should be jpegs or uncompressed tiff files.
Other formats are okay, but you risk having problems with the analysis programs. I recommend using
lossless compression where possible (e.g., tiffs), then converting to jpegs for the analysis if you want to
work with smaller files.

3. Always use a scale bar. Take your photos with a ruler visible in the picture, preferably not on the edge of
the image (to avoid distortion).



Building a tps file

Before collecting data, you need a tps file, which is basically a list of your specimens.

1. Place all of the images that you want to use (or copies of them) in the same folder. You don’t have to do
this, but I find it helpful.

Possible issues: tps programs have had issues with really long file paths (the file name plus all of the names of the folders
it’s in). To avoid this issue, place your images in My Documents or in the C:\ directory in a folder with a short name (e.g.,
“analysis”). You can move them out after you’re done.

2. Open tpsUtil (Start > All Programs > tps > tpsUtil)

3. Click on “Select an operation” and choose “Build tps file” Step 3] File Operations Help
from the drop-down list. Spetation

4. Select your input directory:
a. Click “Input” (which should now be visible).

Step 4 Inputfile or directory
pEZIN

b. Find your directory of images Datafile =1
. . . . s 5 utput tile
c. Double-click one image in that directory output
P
-instead of “Data file = ?”, it should show the path to Outputfle = ?

your images

5. Name your output file
a. Click “Output”
b. Enter a name that ends in “.tps”. I recommend you save this file in the folder with your images.

-instead of “Output file = ?”, it should show the path to your images

6. Build the tps file
a. Click “Setup” (which should now be visible).
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b. Checked images will be used to build your tps file. et e v oeesoal | (4 us| [ ¥ on
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. ) . v NFWFL_2079_5_Lasso_sc: X cancel
c. Confirm that you have a file named “[something].tps v NFWFL_2813 V5_Lassa_sc:
“r: 5 | NPWFL_JB17_Y5_Lasso_sCi  /bja g pe created:
under “File to be created”. If not, go back to step 5. v NFWFL_302_V5_Lasso_scal
vl WFWFL_3939_V5_Lasso_sti/ testtps
d. Click “Create”
e. Click “Close” to exit tpsUtil.

You should now have a file that you can open in tpsDig
(http://life.bio.sunysb.edu/morph/).

| Leave unchecked

What a raw tps file looks like (open in a text editor like Notepad):

LM=0
IMAGE=MSB 125 oscoxae lateral.JPG
LM=0
IMAGE=MSB 54742 oscaxae lateral.JPG

Your specimens (given by the IMAGE= names) currently have zero landmarks (LM=0).



Landmarking your specimens

In this step you place landmarks on your images and save them into your tps file.

1. Open tpsDig (Start > All Programs > tps > tpsDig

2. Open your raw tps file (File > Input Source > File...)
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You should now be able to scroll through all of your images using either the right and left arrow keys (on
your keyboard) or the red arrow buttons on the top left hand corner of the navigation screen. The file name
is listed at the bottom of the screen, and information on the number of landmarks will appear there as you
begin collecting data. The help files are worth a look.

3. Place landmarks. Select the crosshairs icon. Left-click to place a landmark at the appropriate location.

Remember: all landmarks must be placed in sequence. If you click a landmark (LM) with the arrow tool, the LM number will
be shown at the bottom of the screen. If you've screwed up the sequence, you can move the LMs with the arrow tool. Right-
clicking on a landmark with the arrow tool will allow you to delete that LM or insert a new LM before the selected LM.

Make sure you know what your landmarks are before you start and be ready to make adjustments them after
you start. This happens sometimes with ambiguous (e.g., non-Type I) landmarks. Consistency in landmark
placement is critical, so it is important to spend a good amount of time preparing and thinking about where
your landmarks will go.



4. Set scale. Go to Options > Set Scale. In the pop-up window select the length of your scale (e.g., if you
have a 10cm ruler, enter 10.0). In your image, place the cursor (now an arrow with a cross) on one end of
your ruler. Left-click, then set the arrow at the other end and left-click again. The scale window should
now show your scale factor. Click OK.

Do you need to set scales? The ability to set scales in tpsDig is extremely useful and | believe it should always be used. It
allows you to photograph specimens without worrying about the distance between the lens and the specimen by using the
scale bar in your images and inserting a scale adjustment into the tps file. Even if you know that your lens was always at
an equal distance, it does not hurt to set a scale. You can set the scale for each specimen as you landmark, or come back to it
later.

5. Save your landmark data. File > Save data > Save > Overwrite. Because these programs are made by indi-
viduals and not corporations, they are prone to minor glitches (that can make you lose valuable informa-
tion). Therefore, save often! Or don’t, and learn the hard way.

Repeat this process for each specimen. Your tps file should now look like this:

LM=4

563.00000 732.00000

432.00000 749.00000

435.00000 678.00000

572.00000 685.00000
IMAGE=MSB 125 cranium lateral.JPG
ID=1

SCALE=0.006664

Note that each specimen starts with “LM="" and ends with the scale factor. Occasionally, you may find yourself manually
editing files in Notepad. It can be confusing having the specimen name at the end of the specimen data. Be careful about this.
The ID number doesn’t matter; you can concatenate files so that there are multiple specimens with the same ID. | haven't yet
seen a problem with doing so.



First and foremost, we must perform Procrustes Superimposition on the raw landmark data. The following
are instructions for using tpsRelW.

1. Open tpsRelW
2. Open your tps file with all of the landmark data (File > Open)

3. Compute Consensus, Partial Warps, and Relative Warps by clicking on the relevant buttons in order. As
you click a button, the next one becomes clickable.
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4. Save the following for later statistical analysis: Weight Matrix, Centroid Size, Relative Warp Scores.

=; Relative war ps Analysis

(5-8 Actions Options  Help

Open daka File. . Display

1 CiiU_lictoralis_pelves.tps _pelvesips Consensus
Open link file ...

Open sliders file ... TEE Partial warps
Wiew repark...

Clear report Relative warps
[ seve | dlignedspec

et

Bending energy makrix ...

Principal warps matrix ...

Centroid size

U matriz. ..

Weight matrix. ..
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5. You may also want to save the report of the RW analysis, by selecting “View Report” in the same drop-
down menu. The report will pop-up in a separate window and you can save it as a text file.

As you can see, there are many other bits of data that you can save here. I am just alerting you to the abso-
lute basics.



Data export

You may find that you want to run analyses using statistical programs like SPSS or even in EXCEL. This
will require that you transfer/transform the data. The following steps will allow you to transfer data from tps
output formats into EXCEL, which should then be easy to import into any standard stats package.

1. Create an Excel spreadsheet with your specimens as rows and your variables as columns. It will look
something like this:

Microsoft Excel - U littoralis_female_crania
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w il E - @ > pvial Bl B 1 i}

v XV & PW3

A | B | € | D | E F_ 1
Jspeclmen sex (m=0, f=1) centroid PW1 PW2 .
LACM_31012
3 LACM_31067
4 LACM_5794
5 |LACM_B6392
6 |LACM_6394
7
8
9

-

b
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LACM_B414
10 |LACM_B415
11 LACM_7439%
12 LACM_74998
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16 | SBMNH_1935
17 |SBMNH_1998
18 | SBMNH_2001
19 | SBMNH_2063

20 =
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Enter

The order of specimens in this file should be the same as that of the tps file. Using a unique ID for each
specimen is highly useful.

2. Import Centroid Size.
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If this is correct, choose Mext, or choose the data type that best describes your data.
Original data type:
Choose the file type that best describes your data:
(+ pelimited - Characters such as commas or tabs separate each field.
" Fixedwidth - Fields are aligned in columns with spaces between each field.

Start import at row: 1 E‘ File: origin: 437 : OEM United States v

Preview of file C:\Documents and SettingsiHeidiiMy Documents\DATA\D.. \RW_46.NTS,

[1|" Relative warp scores (W) matrix =
|z 461 24 0
3_012345673910111316].7181920212223242501
[45.1380: 4 SE- -8. 1E-003 3. S18645E-
|sl.53164988968746E-003 -1. 703437601.[63871? 003 4.214984528810558-{ |
KT I

Cancel k

3 Ensh |
a. Go to File > Open File (make sure you choose to see all files) and select your centroid size nts file.
b. Select Delimited, click Next.

c. Under Delimiters, select Tab; click Next, then Finish. This should produce an Excel spreadsheet with
centroid size.

d. Copy the column with centroid sizes onto your spreadsheet. Remember that there should be as many
centroid sizes as there are specimens, no more no less.



3. Import shape data.

There are two ways to do this: using macros in Excel or formatting the data in Word or another word pro-
cessing program. Macros can be evil, but indispensable when you have large data sets. Below is a step by
step procedure on how to format the data in Excel using macros.

a. Open Excel. Go to File > Open File (make sure you choose to see all files). Select your weight ma-
trix nts file (this file contains the pw and uniform component shape data).

b. As before, we must convert these data: Choose Delimited. Under Delimiters choose Tab and Space .
Click Next, then Finish.

You should now have a file that has columns labeled 1x 1y 2x 2y and so on plus a UniX and a UniY column.
3. Time for the macro:

a. Highlight the first row of actual data you need to move on the spreadsheet. The first 3 rows just
describe the dataset. They are NOT included in the macro (see yellow highlight and red arrows in im-
age below). [ usually delete these.

b. Go to Tools — Macro — Record New Macro-Pick a key-stroke shortcut for your macro.



Further analysis

You can run basic analyses in some of the programs found in http://life.bio.sunysb.edu/morph/ or in http://
www2.canisius.edu/~sheets/morphsoft.html. However, you may find that you want to run analyses using
statistical programs like SPSS or even in EXCEL.

Suggestions???

Other tips

1. Test your data collection. Take five images of each specimen (not all at once; take them on different days
if you can, to make sure your photographic methods are consistent), then landmark them (also at different
times). You can then look at the within-specimen variance relative to other sources, to assess the degree to
which it might affect your analyses.

Dave Polly has found that small differences in the orientation of 3D objects (where you’re trying to line up a
plane with the optical plane) are a minimal source of variance.

2. Read the help files in the tps programs.

3. Subscribe to the morphmet listserve, and don’t be shy about posting questions there if you’re stuck. Also
post any problems you have with the programs. Chances are very good someone’s experienced and solved
your problem. If not, Jim Rohlf will incorporate a fix into the next version of his programs, which every-
one will appreciate.

Suggestions???



